Qlik Sense System Requirements | QMC & Hub Requirement

1. Objective

Today, we will see Qlik Sense System Requirements. In order to install Qlik Sense on your device. You need to make sure your system has all the required configurations. In this article, we have listed all the necessary system requirements.

So, let’s start Qlik Sense System Requirements tutorial.

Qlik Sense System Requirements | QMC & Hub Requirement

Qlik Sense System Requirements | QMC & Hub Requirement

2. Qlik Sense System Requirements

Here is the list of System Requirements for Qlik Sense –

i. Platforms

  • Microsoft Windows Server 2012
  • Microsoft Windows Server 2012 R2
  • MS Windows Server 2016
  • Microsoft Windows 7 (64-bit version only)
  • Microsoft Windows 8.1 (64-bit version only)
  • MS Windows 10 (64-bit version only)

ii. Processors (CPUs)

Multi-core x64 compatible processors.

iii. Memory

A minimum of 8 GB of internal memory is required as Qlik Sense is an in-memory technology which loads data in the internal memory to process and analyze it. More than 8 GB can always be used if there is more data to be analyzed. 

iv. Disk Space

5.0 GB total required to install Qlik Sense.

v. Security

Three types of security services are used.

  • Microsoft Active Directory
  • Microsoft Windows Integrated Authentication
  • Third-party security

vi. .NET Framework

  • 4.5.2 or higher

vii. PowerShell

  • 4.0 or higher

viii. Repository Database

  • PostgreSQL 9.6.x (pgAdmin tools not included and have to be installed manually). It is also the centralized logging database.
  • PostgreSQL is a part of the Qlik Sense setup by default.

ix. Internet Protocol

  • IPv4
  • IPv6
  • Dual stack (IPv4 and IPv6)

x. Qlik Cloud Services

  • Maximum app size: 500 MB
  • Storage: 500 GB

xi. Qlik Sense Enterprise Requirements

  • Kubernetes environment –

Microsoft Azure 1.9.1

Amazon Web Services (AWS) 1.9.7

  • Kubernetes package manager – Helm 2.9.0
  • Database – MongoDB 3.6+
  • File system – NFS 4.1 compliant NFS

xii. Mobile OS

  • iOS 11.2 or later are compatible

3. QMC Requirements

There are specific requirements for Qlik Sense Management Console (QMC).

i. Support Browsers

a. MS Windows 7, Windows 8.1:

  • MS Internet Explorer 11
  • Google Chrome
  • Mozilla Firefox (requires hardware support)

b. Microsoft Windows Server 2012, Windows Server 2012 R2, Windows Server 2016:

  • Microsoft Internet Explorer 11 (not supported on Windows Server 2012)
  • Google Chrome
  • Mozilla Firefox (requires hardware support)

c. MS Windows 10:

  • Microsoft Internet Explorer 11
  • MS Edge
  • Google Chrome
  • Mozilla Firefox (requires hardware support)

d. Apple Mac OS X 10.11 and 10.12:

  • Apple Safari
  • Google Chrome
  • Mozilla Firefox (requires hardware support)
  • CefSharp embedded browser v55 or later

ii. Screen Resolution

Desktops, laptops, and Apple Mac: 1024×768 but no mobile or small screen support.

4. Qlik Sense Hub Requirements

i. Microsoft Windows 7

  • Microsoft Internet Explorer 11
  • Google Chrome
  • Mozilla Firefox (requires hardware support)

ii. MS Windows 8.1

  • Microsoft Internet Explorer 11
  • Google Chrome
  • Mozilla Firefox (requires hardware support)

iii. MS Windows 10

  • Microsoft Edge
  • MS Internet Explorer 11
  • Google Chrome
  • Mozilla Firefox (requires hardware support)

iv. Apple Mac OS X 10.11 and 10.12

  • Apple Safari 10 or later
  • Google Chrome
  • Mozilla Firefox

v. MS Windows Server 2012

  • Google Chrome
  • Mozilla Firefox

vi. Microsoft Windows Server 2012 R2

  • MS Internet Explorer 11
  • Google Chrome
  • Mozilla Firefox

vii. MS Windows Server 2016

  • MS Internet Explorer 11
  • Google Chrome
  • Mozilla Firefox
  • CefSharp embedded browser v55 or later

viii. iOS Compatibility

  • Version 11.2 or later
  • Qlik Sense Enterprise September 2017 or later.

Supported devices:

  • iPad Air or later
  • iPhone 5S or later

Supported browsers:

  • Apple Safari
  • Google Chrome
  • VMware browser
  • BlackBerry Access 2.9.1 or later
  • iOS 11.3

ix. Android compatibility

Android versions:

  • 4.4.4
  • 5.1.1
  • 6.0
  • 7.0

Although script editing is not supported on tablet devices

Google Chrome

BlackBerry Access 2.9.1 or later

x. Windows 10 phone

  • MS Edge

So, this was all in Qlik Sense System Requirement. Hope you liked our explanation.

5. Conclusion

Hence, in this tutorial, we saw the system requirements for Qlik Sense. Moreover, we discussed QMC and hub requirements in Qlik Sense. So, make sure that your device or system is ready to install and support Qlik Sense’s functioning with all the requirements that are needed.

Still, if you have any doubt regarding Qlik Sense System Requirements, ask in the comment tab.

Reference for Qlik Sense

Leave a Reply

Your email address will not be published. Required fields are marked *

This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.