Front Page Forums Apache Flink Getting error org.apache.flink.runtime.jobmanager.JobManager

This topic contains 1 reply, has 1 voice, and was last updated by  DataFlair Team 2 months, 1 week ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #6611

    DataFlair Team
    Participant

    I am trying to install below mentioned version of Apache Flink on multi node cluster on Amazon AWS EC2,
    flink-1.1.3-bin-hadoop26-scala_2.11.tgz

    Once I run below command to start the services of cluster
    bin/start-cluster.sh,
    Task Manager is getting start but Job Manager is not getting start in cluster. once I checked logs I am getting below errors:

    2016-12-02 17:51:12,764 INFO org.apache.flink.runtime.jobmanager.JobManager – Registered UNIX signal handlers for [TERM, HUP, INT]
    2016-12-02 17:51:13,119 INFO org.apache.flink.runtime.jobmanager.JobManager – Loading configuration from /home/ubuntu/flink-1.1.3/conf
    2016-12-02 17:51:13,149 INFO org.apache.flink.runtime.jobmanager.JobManager – Starting JobManager without high-availability
    2016-12-02 17:51:13,162 INFO org.apache.flink.runtime.jobmanager.JobManager – Starting JobManager on 52.201.251.149:6123 with execution mode CLUSTER
    2016-12-02 17:51:13,458 INFO org.apache.flink.runtime.jobmanager.JobManager – Security is not enabled. Starting non-authenticated JobManager.
    2016-12-02 17:51:13,475 INFO org.apache.flink.util.NetUtils – Unable to allocate on port 6123, due to error: Cannot assign requested address
    2016-12-02 17:51:13,477 ERROR org.apache.flink.runtime.jobmanager.JobManager – Failed to run JobManager.
    java.lang.RuntimeException: Unable to do further retries starting the actor system
    at org.apache.flink.runtime.jobmanager.JobManager$.retryOnBindException(JobManager.scala:2116)
    at org.apache.flink.runtime.jobmanager.JobManager$.runJobManager(JobManager.scala:2056)
    at org.apache.flink.runtime.jobmanager.JobManager$.main(JobManager.scala:1981)

    I am following this blog to install Flink on http://data-flair.training/blogs/install-run-deploy-flink-multi-node-cluster/

    Please resolve the issue.

    #6612

    DataFlair Team
    Participant

    While installing Flink on AWS use private IP instead of public IP while specifying jobmanager.rpc.address in flink-conf.yaml

    Actually there is a bug related to bind and configurations, for more information visit the Jira:
    https://issues.apache.org/jira/browse/FLINK-2821

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.